Прогнозирование цены акций на рынке ценных бумаг в Excel. Модель Moving Average

Написано admin в 6 января, 2012. Опубликовано в Рынок ценных бумаг

Скользящее среднее или просто МА (Moving Average), является среднеарифметическим ценового ряда.  Общая формула скользящего среднего следующая:
Формула скользящего среднего
где:
МА – скользящее среднее;
n- период усреднения;
Х – значения цены акции.

Для прогнозирования цены акции на несколько периодов вперед воспользуемся формулой. Прогноз цены в следующем период будет равнять значения скользящего среднему в предыдущем периоде.

Формула прогноза
Спрогнозируем с помощью модели скользящего среднего стоимость акций компании Аэрофлот (AFLT). Для этого экспортируем котировки акции с сайта finam.ru за  половину 2009 года. Всего будет 20 значений.

Котировки ценных бумаг

 

График стоимости акций Аэрофлота за выбранный промежуток времени представлен ниже.

Котировки акций Аэрофлота

Выбор периода усреднения
n в модели скользящего среднего
Использование большего в модели МА(n) приводит к сильному искажению  данных, в результате чего  существенные значения ценового ряда усредняются, и в результате теряется четкость прогноза, можно сказать что он становится “размытым”. Использование слишком мелкого периода усреднения добавляет в прогноз больше шумовой компоненты. Как правило, период усреднения подбирается эмпирическим путем на исторических данных.

Построим скользящее среднее с периодом усреднения в три месяца MA(3). Для расчета значения скользящего среднего для акции, воспользуемся формулой Excel.

=СРЗНАЧ(C2:C4)

В колонке “D” рассчитаны значения скользящего среднего с периодом усреднения 3.

Построение скользящей средней в Excel

После расчета скользящего среднего построим прогноз на 3 периода вперед (на три месяца вперед). Воспользуемся формулой для определения значения цены акции, первое прогнозное значение будет равно последнему значению скользящего среднего. Оранжевая область это область прогнозов. С22 будет равна значению скользящего среднего, то есть:

С22 =D21
С23=D22 и т.д.

От новых прогнозных данных стоимости акции рассчитывается скользящее следующее среднее.

Построение прогноза, пример

Построим прогнозные значения по скользящему среднему для акций Аэрофлота на три месяца вперед. Ниже представлен график и прогнозные значения акции.

Прогноз акций

Заключение

Использование модели MA для прогнозирования временных рядов и в частности цены акций достаточно эффективно. Скользящее среднее относится к линейным методам прогнозирования и поэтому наибольший эффект достигается при использовании на низковолатильных рынках и акциях. При наличии нелинейности на рынке, особенно это характерно для российского фондового рынка, увеличивается ошибка при использовании этих моделей.

Теги:, , , ,

Trackback с вашего сайта.

Оставить комментарий

Войти

Новости

Полезное

Изменить "Кол-во"
Ежедневный курс иностранной валюты ЦБ РФ на 15.05.2021
ВалютаКол-воРубль RUB
Продажа (руб.)
Доллар США USD
Евро EUR
Фунт стерлингов Соединенного королевства GBP
Use data from the cache